ส่งข้อความหนึ่งฉบับไปยังที่อยู่อีเมลชั่วคราว แล้วระบบจะดำเนินการตรวจสอบ 42 รายการ หน้านี้รวมทั้งหมดไว้แล้ว: แต่ละรายการตรวจสอบอะไร หักคะแนนของคุณเท่าใดเมื่อตรวจสอบไม่ผ่าน และมาจากส่วนใดของมาตรฐาน
ไม่มีสิ่งใดในหน้านี้ที่เป็นความคิดเห็นของเราซึ่งนำมาเขียนให้ดูเหมือนกฎ ในกรณีที่การตรวจสอบบังคับใช้สิ่งที่มาตรฐานระบุไว้ ประโยคจากมาตรฐานนั้นจะถูกอ้างไว้ด้านล่าง ในกรณีที่บังคับใช้ข้อกำหนดของ Google หรือ Yahoo แทน จะมีลิงก์ไปยังหน้าของผู้ให้บริการนั้น ในกรณีที่เป็นดุลยพินิจของเราเอง จะมีการระบุไว้อย่างชัดเจน
การยืนยันตัวตน
เซิร์ฟเวอร์ผู้รับสามารถพิสูจน์ได้หรือไม่ว่าข้อความมาจากแหล่งที่อ้างไว้ นี่คือครึ่งหนึ่งของความสามารถในการส่งถึงผู้รับที่ขึ้นอยู่กับ DNS ล้วน ๆ และเป็นครึ่งที่ Gmail และ Yahoo กำหนดให้ผู้ส่งจำนวนมากต้องปฏิบัติตามในปี 2024
เชน ARC auth.arc
ARC รักษาผลการยืนยันตัวตนไว้เมื่อผ่านตัวส่งต่อ หากไม่มี ARC เมลลิงลิสต์ที่เพิ่มส่วนท้ายจะทำให้ลายเซ็น DKIM ของคุณใช้ไม่ได้ และสำเนาที่ส่งต่อจะไม่ผ่าน DMARC ที่ปลายทาง
หากไม่ผ่าน: ผู้ส่งไม่ต้องทำอะไร เรื่องนี้สำคัญหากคุณดูแลลิสต์หรือตัวส่งต่อ และอธิบายว่าทำไมอีเมลบางฉบับของคุณจึงไม่ผ่าน DMARC หลังจากมีผู้ส่งต่ออีเมลนั้น
มีผล สูงสุด 2 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
RFC 7960 §1 — Introduction
DMARC with restrictive policies causes problems for many Mailing Lists.
RFC 8617 §2.1 — Evidence
In ARC's situation, the "evidence" is a message's authentication assessment at any point along the delivery path between origination and final delivery.
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
ลายเซ็น DKIM auth.dkim
DKIM ลงนามบางส่วนของข้อความด้วยคีย์ส่วนตัวและเผยแพร่คีย์สาธารณะใน DNS เราตรวจสอบลายเซ็นทุกรายการที่มากับข้อความ และรายงานโดเมนที่ลงนาม selector และความยาวคีย์
หากไม่ผ่าน: เปิดใช้ DKIM ที่แพลตฟอร์มส่งอีเมลของคุณและเผยแพร่คีย์ที่แพลตฟอร์มมอบให้ ใช้ 2048 บิต: 1024 บิตยังตรวจสอบได้ แต่คีย์ที่สั้นขนาดนี้ถูกถอดรหัสได้และไม่ปลอดภัยอีกต่อไป
มีผล สูงสุด 18 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 1 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
RFC 6376 §3.5 — The DKIM-Signature Header Field
The signature of the email is stored in the DKIM-Signature header field.
RFC 6376 §6.1 — Extract Signatures from the Message
Verifiers MUST NOT attribute ultimate meaning to the order of multiple DKIM-Signature header fields.
RFC 8301 §3.1 — Signing and Verification Algorithms
rsa-sha1 MUST NOT be used for signing or verifying.
RFC 8463 §6 — Transition Considerations
For backward compatibility, signers can add multiple signatures that use old and new signing algorithms.
Google — Set up DKIM
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
การจัดแนว DKIM auth.dkim_alignment
ลายเซ็นที่ถูกต้องเพียงอย่างเดียวยังไม่เพียงพอสำหรับ DMARC โดเมนที่ลงนามต้องตรงกับโดเมนในส่วนหัว From ทุกประการ หรือตรงกันในระดับโดเมนองค์กร ขึ้นอยู่กับนโยบายที่คุณเผยแพร่
หากไม่ผ่าน: ลงนามด้วยโดเมนของคุณเองแทนโดเมนของแพลตฟอร์ม แพลตฟอร์มส่วนใหญ่รองรับสิ่งนี้และเรียกว่าโดเมนส่งอีเมลแบบกำหนดเองหรือผ่านการตรวจสอบสิทธิ์
มีผล สูงสุด 10 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 1 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
RFC 9989 §4.4.1 — DKIM-Authenticated Identifiers
A single email can contain multiple DKIM signatures, and it is considered to produce a DMARC "pass" result if any DKIM-Authenticated Identifier aligns with the Author Domain.
Google — Set up DMARC
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
ผลลัพธ์ DMARC auth.dmarc
DMARC เชื่อมโยง SPF และ DKIM เข้ากับโดเมนที่ผู้อ่านเห็น และบอกผู้รับว่าต้องทำอย่างไรเมื่อทั้งสองรายการไม่จัดแนว เรารายงานนโยบายที่เผยแพร่และข้อความนี้เป็นไปตามนโยบายนั้นหรือไม่
หากไม่ผ่าน: เผยแพร่ระเบียน DMARC เริ่มต้นที่ p=none อ่านรายงานเป็นเวลาสองสามสัปดาห์ แล้วจึงเปลี่ยนเป็น quarantine เมื่อคุณทราบแล้วว่ามีระบบใดอีกบ้างที่ส่งอีเมลในนามของคุณ
มีผล สูงสุด 14 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
RFC 9989 §5.3.5 — Determine DMARC "Pass" or "Fail"
If no Authenticated Identifiers exist for the domain, or none of the Authenticated Identifiers align with the Author Domain, the message is considered to fail the DMARC mechanism check.
RFC 9989 §4.7 — DMARC Policy Record Format
DMARC Policy Records follow the extensible "tag-value" syntax for DNS-based key records defined in DKIM [RFC6376].
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
Yahoo — Sender requirements and recommendations
Sender ID auth.sender_id
เป็นการตรวจสอบแบบเดียวกับ SPF แต่ทำกับโดเมนในส่วนหัว From แทน envelope การตรวจสอบนี้ตอบคำถามที่ต่างออกไปว่าโดเมนที่ผู้อ่านเห็นอนุญาตเซิร์ฟเวอร์ที่ส่งข้อความหรือไม่ ข้อความอาจผ่าน SPF สำหรับ envelope ขณะที่โดเมนที่มองเห็นไม่ได้รับรองเซิร์ฟเวอร์ใดเลย
หากไม่ผ่าน: เผยแพร่ SPF สำหรับโดเมนในส่วนหัว From ไม่ใช่เฉพาะโดเมน bounce ที่แพลตฟอร์มมอบให้คุณ
มีผล สูงสุด 5 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 0.5 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
RFC 4406 §4 — Record Selection
After the above steps, there should be one record remaining and evaluation can proceed.
SPF auth.spf
SPF คือระเบียน DNS ที่ระบุว่าเซิร์ฟเวอร์ใดบ้างที่ส่งอีเมลให้โดเมนของคุณได้ เซิร์ฟเวอร์ผู้รับจะนำที่อยู่ใน envelope ไปค้นหาระเบียนของโดเมนนั้น และตรวจสอบว่า IP ที่เชื่อมต่ออยู่ในระเบียนหรือไม่ เรารายงานผลและจำนวนการค้นหา DNS ที่จำเป็นในการประเมินระเบียน เพราะการประเมินจะหยุดที่สิบครั้ง และหากเกินกว่านั้นจะถือเป็นข้อผิดพลาดถาวรแทนที่จะผ่าน
หากไม่ผ่าน: เผยแพร่ระเบียนที่ระบุแพลตฟอร์มส่งอีเมลของคุณและไม่มีรายการอื่น หากระเบียนของคุณใกล้ถึงขีดจำกัดการค้นหาสิบครั้ง ให้ทำ flatten กับ include ที่คุณไม่ได้ใช้ (ระเบียนที่ผ่านในวันนี้จะเริ่มไม่ผ่านในวันที่ผู้ให้บริการเพิ่ม include ของตนเอง)
มีผล สูงสุด 18 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 1 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
RFC 7208 §4.6.4 — DNS Lookup Limits
SPF implementations MUST limit the total number of those terms to 10 during SPF evaluation, to avoid unreasonable load on the DNS. If this limit is exceeded, the implementation MUST return "permerror".
RFC 7208 §2.6 — Results of Evaluation
Section 4 defines check_host(), a model function definition that uses the inputs defined above and the sender's policy published in the DNS to reach a conclusion about client authorization.
Google — Set up SPF
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
การจัดแนว SPF auth.spf_alignment
ตรวจสอบว่าที่อยู่ bounce ตรงกับที่อยู่ From ที่ผู้อ่านเห็นหรือไม่ SPF อนุญาต envelope และ DMARC จะนับการอนุญาตนั้นก็ต่อเมื่อทั้งสองรายการจัดแนวกัน
หากไม่ผ่าน: ขอให้แพลตฟอร์มส่งอีเมลจัดสรรโดเมนย่อยสำหรับ bounce ภายใต้โดเมนของคุณเอง หาก DKIM ของคุณจัดแนวแล้ว เรื่องนี้ไม่เร่งด่วน แต่คุณจะไม่มีตัวสำรองเมื่อ DKIM เสียหายระหว่างการส่งต่อ
มีผล สูงสุด 5 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 0.5 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
RFC 9989 §4.4.2 — SPF-Authenticated Identifiers
Only an SPF-Authenticated Identifier that has Identifier Alignment with the Author Domain is enough to validate the authorized use of the Author Domain.
RFC 9989 §5.3.5 — Determine DMARC "Pass" or "Fail"
If one or more of the Authenticated Identifiers align with the Author Domain, the message is considered to pass the DMARC mechanism check.
Google — Set up DMARC
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
โครงสร้างพื้นฐานและชื่อเสียง
เครื่องและที่อยู่ที่ใช้ส่งข้อความ รวมถึงสิ่งที่อินเทอร์เน็ตส่วนอื่นประเมินเกี่ยวกับทั้งสองรายการนี้อยู่แล้ว
ชื่อโฮสต์ผู้ส่งแปลงค่าได้ infra.a_record
ชื่อโฮสต์ที่ประกาศใน HELO มีระเบียนที่อยู่หรือไม่
หากไม่ผ่าน: เผยแพร่ระเบียน A สำหรับชื่อที่เซิร์ฟเวอร์ของคุณประกาศ
มีผล สูงสุด 5 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 3 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
RFC 5321 §5.1 — Locating the Target Host
If an empty list of MXs is returned, the address is treated as if it was associated with an implicit MX RR, with a preference of 0, pointing to that host.
Google — Set up MX records
รายการบล็อก infra.dnsbl
ตรวจสอบว่า IP ที่ใช้ส่งอยู่ในรายการของรายการบล็อกใดที่ผู้รับตรวจสอบจริงหรือไม่ รายการของเราถูกตรวจสอบกับจุดทดสอบที่แต่ละโซนระบุไว้ในเอกสารของตนเอง แทนที่จะรวบรวมจากการค้นหาเว็บ เพราะโซนที่หยุดให้บริการจะตอบ NXDOMAIN และผลนั้นจะถูกอ่านว่า "สะอาด"
หากไม่ผ่าน: ทำตามกระบวนการนำออกจากรายการบนเว็บไซต์ของผู้ให้บริการรายการนั้น การติดรายการในโซนหลักจะทำให้อีเมลถูกปฏิเสธทันที ดังนั้นให้จัดการเรื่องนี้ก่อนรายการอื่นทั้งหมดในหน้า
มีผล สูงสุด 25 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 3 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
RFC 5782 §2.1 — IP Address DNSxL
Each IPv4 address listed in the DNSxL has a corresponding DNS entry.
RFC 5782 §5 — Test and Contact Addresses
IPv4-based DNSxLs MUST contain an entry for 127.0.0.2 for testing purposes.
Google — Postmaster Tools: reputation and delivery errors
Google — Email sender guidelines
ชื่อ HELO infra.helo
ชื่อที่เซิร์ฟเวอร์ผู้ส่งใช้ประกาศตัวเองเมื่อเริ่มการสนทนา SMTP ชื่อนี้ต้องเป็นชื่อโดเมนแบบเต็มที่แปลงค่าได้
หากไม่ผ่าน: ตั้งค่าชื่อโฮสต์ของเซิร์ฟเวอร์อีเมลเป็นชื่อจริงในโดเมนของคุณ ไม่ใช่ ID ของคอนเทนเนอร์หรือชื่อภายใน
มีผล สูงสุด 5 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
RFC 5321 §4.1.1.1 — Extended HELLO (EHLO) or HELLO (HELO)
The argument clause contains the fully-qualified domain name of the SMTP client, if one is available.
Google — Email sender guidelines
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
ระเบียน MX infra.mx
โดเมนในส่วนหัว From ของคุณรับอีเมลได้หรือไม่ หากไม่มีระเบียนนี้ อีเมลตอบกลับและอีเมลตีกลับจะไม่มีปลายทาง และตัวกรองมองว่าโดเมนผู้ส่งที่รับอีเมลไม่ได้เป็นสัญญาณที่ไม่ดี
หากไม่ผ่าน: เผยแพร่ระเบียน MX สำหรับโดเมนที่คุณใช้ส่ง แม้ว่าระเบียนนั้นจะเพียงกำหนดเส้นทางไปยังกล่องจดหมายที่คุณเปิดอ่านเดือนละครั้งก็ตาม
มีผล สูงสุด 5 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 3 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
RFC 5321 §5.1 — Locating the Target Host
The lookup first attempts to locate an MX record associated with the name.
Google — Set up MX records
DNS ย้อนกลับ infra.rdns
IP ที่ใช้ส่งแปลงค่าย้อนกลับเป็นชื่อโฮสต์หรือไม่ และชื่อโฮสต์นั้นแปลงค่าไปข้างหน้าเป็น IP เดิมหรือไม่ ประเด็นคือการตรวจสอบไปกลับ: การกำหนดให้ PTR ชี้ไปที่ใดก็ได้นั้นทำได้ง่าย แต่คู่ที่ตรงกันเป็นหลักฐานว่าที่อยู่นั้นเป็นของคุณ
หากไม่ผ่าน: ขอให้ผู้ที่เป็นเจ้าของ IP ตั้งค่า PTR เป็นชื่อที่คุณควบคุม และตรวจสอบให้แน่ใจว่าชื่อนั้นมีระเบียน A ที่ชี้กลับไปยัง IP ดังกล่าว
มีผล สูงสุด 12 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 1.5 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
RFC 1912 §2.1 — Inconsistent, Missing, or Bad Data
Make sure your PTR and A records match. For every IP address, there should be a matching PTR record in the in-addr.arpa domain.
Google — Email sender guidelines
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
การเข้ารหัสระหว่างส่ง infra.tls
ข้อความมาถึงผ่าน TLS หรือไม่ และใช้ชุดรหัสใด ระบบสมัยใหม่ทั้งหมดจะเจรจาใช้ TLS; ข้อความที่มาถึงโดยไม่มีการเข้ารหัสบ่งบอกบางอย่างเกี่ยวกับการตั้งค่าการส่ง
หากไม่ผ่าน: เปิดใช้ STARTTLS บนเซิร์ฟเวอร์ผู้ส่ง แพลตฟอร์มหลักทุกแพลตฟอร์มรองรับสิ่งนี้อยู่แล้ว ดังนั้นความล้มเหลวในส่วนนี้มักหมายความว่ามีรีเลย์ที่โฮสต์เองอยู่ในเส้นทาง
มีผล สูงสุด 5 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
RFC 3207 §2 — STARTTLS Extension
The STARTTLS extension to SMTP is laid out as follows:
Google — Send email over a secure TLS connection
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
ระบบตรวจจับสแปม
ตัวกรองเนื้อหาอิสระประเมินข้อความอย่างไร ใช้สองระบบแทนที่จะเป็นระบบเดียว เพราะคะแนนจากระบบเดียวเป็นความคิดเห็นของระบบนั้น
ผู้ตัดสิน AI spam.ai_judge
โมเดลประเมินว่าตัวกรองแบบแมชชีนเลิร์นนิงสมัยใหม่จะจัดการกับข้อความอย่างไร โดยอิงจากผลการตรวจสอบทางเทคนิคและการวัดเนื้อหา โมเดลจะเห็นข้อเท็จจริง ไม่ใช่ข้อความในเนื้อหา
หากไม่ผ่าน: ใช้เป็นรายละเอียดเท่านั้นเมื่อพิจารณาแยกต่างหาก ค่าประเมินของโมเดลจะนำไปใช้ในคำตัดสินรวมด้านล่าง
แสดงไว้เพื่อให้รายละเอียด ไม่มีการคิดคะแนน
คำตัดสินรวม spam.panel
ตัวเลขหนึ่งค่าจากเอนจินที่ตอบกลับ โดยถ่วงน้ำหนักเพื่อไม่ให้ผลที่รุนแรงที่สุดถูกเฉลี่ยจนหายไป SpamAssassin และ Postmark นับเป็นหนึ่งเสียงร่วมกัน เพราะใช้ฐานกฎเดียวกัน
หากไม่ผ่าน: ไล่ตรวจสอบผลการตรวจสอบแต่ละรายการ แถวนี้จะเปลี่ยนเมื่อรายการเหล่านั้นเปลี่ยน
มีผล สูงสุด 25 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
Google — Why Gmail marks messages as spam
How this score is calculated
Postmark SpamCheck spam.postmark
ความเห็นที่สาม ซึ่งปิดไว้โดยค่าเริ่มต้น เอนด์พอยต์ของบริการนี้รับข้อความทั้งหมด และเราไม่สามารถปกปิดส่วนใดได้โดยไม่ทำลายสิ่งที่กำลังวัด ดังนั้นการเปิดใช้งานหมายถึงการยอมรับว่าข้อความทุกฉบับที่ทดสอบจะถูกคัดลอกไปยังบุคคลที่สาม
หากไม่ผ่าน: ไม่ต้องดำเนินการใด เมื่อปิดอยู่ การตรวจสอบจะรายงานว่าปิดอยู่ ซึ่งไม่เหมือนกับการผ่าน
แสดงไว้เพื่อให้รายละเอียด ไม่มีการคิดคะแนน
Rspamd spam.rspamd
ตัวกรองอีกตัวหนึ่งที่พัฒนาขึ้นอย่างอิสระ ตัวกรองนี้เห็นต่างจาก SpamAssassin บ่อยพอที่จะควรนำมาพิจารณา ซึ่งเป็นเหตุผลที่ตัวกรองนี้อยู่ที่นี่
หากไม่ผ่าน: ใช้เป็นรายละเอียดเท่านั้น ความเห็นของเอนจินนี้จะรวมอยู่ในคำตัดสินรวมแทนที่จะให้คะแนนแยกต่างหาก
แสดงไว้เพื่อให้รายละเอียด ไม่มีการคิดคะแนน
SpamAssassin spam.spamassassin
ตัวกรองแบบอิงกฎดั้งเดิม ซึ่งยังคงเป็นเอนจินเบื้องหลังเครื่องมือทดสอบอีเมลส่วนใหญ่ กฎทุกข้อที่ถูกเรียกใช้จะแสดงพร้อมค่าน้ำหนัก
หากไม่ผ่าน: อ่านกฎที่ถูกเรียกใช้แทนที่จะดูคะแนนรวม ส่วนใหญ่แก้ได้ง่ายเมื่อเห็นว่าเป็นกฎใดบ้าง
มีผล สูงสุด 3 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
Google — Why Gmail marks messages as spam
Apache SpamAssassin — rule documentation
เนื้อหา
ตัวข้อความเอง: โครงสร้าง ลิงก์ รูปภาพ และสิ่งต่าง ๆ ที่ตัวกรองอ่านก่อนตัดสินใจ
ข้อความ alt ของรูปภาพ content.alt_attributes
รูปภาพมีแอตทริบิวต์ alt หรือไม่ ไคลเอนต์อีเมลจะบล็อกรูปภาพจากระยะไกลตามค่าเริ่มต้น ดังนั้นในช่วงสองสามวินาทีแรก ข้อความ alt จึงเป็นข้อความของคุณ
หากไม่ผ่าน: เขียนข้อความ alt ที่สื่อความหมาย และอย่าปล่อยให้ภาพหลักไม่มีข้อความ alt
มีผล สูงสุด 4 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 0.5 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
Google — Email sender guidelines
ความพร้อมใช้งานของลิงก์ content.broken_links
ลิงก์ในข้อความเปิดไปยังปลายทางได้หรือไม่ ลิงก์เสียในจดหมายข่าวทำให้สูญเสียความน่าเชื่อถือทันที และตัวกรองก็ตรวจพบเช่นกัน
หากไม่ผ่าน: แก้ไขหรือลบลิงก์เหล่านั้น ตรวจสอบโดเมนติดตามด้วย: หากหมดอายุ ลิงก์ทั้งหมดจะเสียพร้อมกัน
มีผล สูงสุด 5 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 1 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
Google — Why Gmail marks messages as spam
Script และ iframe content.forbidden_tags
HTML มีแท็กที่ไม่มีไคลเอนต์อีเมลใดเรียกใช้หรือไม่ อย่างดีที่สุดแท็กเหล่านี้จะถูกลบออก และอย่างแย่ที่สุดจะถูกมองว่าเป็นสัญญาณของการหลบเลี่ยง
หากไม่ผ่าน: นำ script, iframe, object และ embed ออก ทุกสิ่งที่โต้ตอบได้ควรอยู่หลังลิงก์
มีผล สูงสุด 10 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 1 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
Google — Email sender guidelines
สัดส่วนข้อความต่อ HTML content.html_text_ratio
ข้อความมีมาร์กอัปมากเพียงใดเมื่อเทียบกับข้อความที่อ่านได้ หน้ามาร์กอัปที่ครอบประโยคเดียวเป็นรูปแบบที่ตัวกรองตรวจจับได้
หากไม่ผ่าน: เขียนส่วนข้อความที่สื่อสารเนื้อหาเดียวกับ HTML แทนการใช้ข้อความตัวอย่าง
มีผล สูงสุด 3 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 0.3 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
RFC 2046 §5.1.4 — Alternative Subtype
Systems should recognize that the content of the various parts are interchangeable.
Google — Why Gmail marks messages as spam
ส่วนข้อความและ HTML content.html_version
ข้อความมีเวอร์ชันข้อความล้วนเป็นทางเลือกควบคู่กับ HTML หรือไม่ ตัวกรองบางตัวให้น้ำหนักกับการไม่มีส่วนนี้ และโปรแกรมอ่านหน้าจอทุกตัวต้องการส่วนนี้
หากไม่ผ่าน: ส่งแบบ multipart/alternative ที่มีเวอร์ชันข้อความจริง ไม่ใช่ส่วนว่างหรือบรรทัดที่บอกให้เปิดดูในเบราว์เซอร์
มีผล สูงสุด 5 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
RFC 2046 §5.1.4 — Alternative Subtype
The "multipart/alternative" type is syntactically identical to "multipart/mixed", but the semantics are different. In particular, each of the body parts is an "alternative" version of the same information.
Google — Email sender guidelines
ขนาด HTML content.html_weight
ส่วน HTML มีขนาดใหญ่เพียงใด Gmail จะตัดข้อความที่มีขนาดเกินประมาณ 102 KB และซ่อนส่วนที่เหลือไว้หลังลิงก์ ซึ่งทำให้ส่วนท้ายสำหรับยกเลิกการสมัครของคุณถูกซ่อนไปด้วย
หากไม่ผ่าน: ลด CSS แบบอินไลน์และบล็อกสไตล์ที่ซ้ำกัน (เทมเพลตส่วนใหญ่มีขนาดไม่เกินหนึ่งในสามของขีดจำกัดเมื่อนำกฎที่ไม่ได้ใช้ออกแล้ว)
มีผล สูงสุด 3 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 0.3 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
Google — Email sender guidelines
ขนาดรูปภาพ content.images_weight
ขนาดรวมของรูปภาพที่ข้อความโหลดเข้ามา รูปภาพขนาดใหญ่ทำให้ข้อความโหลดช้าบนโทรศัพท์ และอีเมลที่มีแต่รูปภาพเป็นรูปแบบที่ตัวกรองมองว่าน่าสงสัย
หากไม่ผ่าน: บีบอัดรูปภาพและตรวจสอบว่าข้อความยังอ่านได้เมื่อปิดการแสดงรูปภาพ
มีผล สูงสุด 3 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 0.3 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
Google — Email sender guidelines
ปลายทางของลิงก์ที่แสดง content.link_mismatch
เปรียบเทียบโดเมนในข้อความลิงก์กับปลายทางหลังการเปลี่ยนเส้นทาง HTTP โดเมนติดตามระหว่างทางเพียงอย่างเดียวไม่ใช่หลักฐานการหลอกลวง
หากไม่ผ่าน: ใช้โดเมนปลายทางหรือข้อความอธิบาย ปลายทางที่เข้าถึงไม่ได้จะยังไม่ผ่านการตรวจสอบ
มีผล สูงสุด 3 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
Google — Email sender guidelines
ชื่อเสียงของลิงก์ content.malicious_links
ตรวจสอบ URL กับรายการภัยคุกคาม การพบข้อมูลตรงกันไม่ได้หมายความว่าผู้รับทุกคนจะบล็อกอีเมล
หากไม่ผ่าน: ตรวจสอบปลายทางที่ถูกระบุแล้วเปลี่ยนหรือลบลิงก์ที่ไม่ปลอดภัย ประวัติเดิมเพียงอย่างเดียวไม่ยืนยันการติดเชื้อในปัจจุบัน
มีผล สูงสุด 40 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
Google — Why Gmail marks messages as spam
การสแกนไฟล์แนบ content.malware
ไฟล์แนบมีมัลแวร์ที่รู้จักหรือไม่ ในระบบที่ปิดใช้งานตัวสแกน รายการนี้จะรายงานว่าไม่ได้ทำการสแกน แทนที่จะรายงานว่าไฟล์ปลอดภัย
หากไม่ผ่าน: หากรายการนี้แจ้งเตือน ให้หยุดส่งและตรวจสอบว่ามีอะไรอยู่ในเครื่องที่ใช้สร้างข้อความ
มีผล สูงสุด 60 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
Google — Why Gmail marks messages as spam
ClamAV — how detection works
บรรทัดหัวเรื่อง content.subject
ความยาว การใช้ตัวพิมพ์ใหญ่ และรูปแบบที่ตัวกรองนำไปให้คะแนน เราวัดหัวเรื่องที่ถอดรหัสแล้ว ดังนั้นบรรทัดที่เป็นอักษรซีริลลิกหรือ CJK จะถูกประเมินเป็นข้อความแทนที่จะเป็นรูปแบบการเข้ารหัส
หากไม่ผ่าน: ให้มีความยาวไม่เกินประมาณ 60 อักขระ เลิกใช้ตัวพิมพ์ใหญ่เหมือนตะโกนและตัดเครื่องหมายอัศเจรีย์ออก
มีผล สูงสุด 3 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
RFC 5322 §2.2 — Header Fields
Header fields are lines beginning with a field name, followed by a colon (":"), followed by a field body, and terminated by CRLF.
RFC 2047 §2 — Syntax of encoded-words
An 'encoded-word' is defined by the following ABNF grammar.
Google — Why Gmail marks messages as spam
ลิงก์แบบย่อ content.url_shortener
ลิงก์ส่งผ่านบริการย่อลิงก์สาธารณะหรือไม่ บริการย่อลิงก์ซ่อนปลายทาง ซึ่งเป็นสิ่งที่ตัวกรองถูกฝึกให้ไม่ไว้วางใจโดยตรง
หากไม่ผ่าน: ลิงก์ไปยังโดเมนของคุณเอง หรือใช้โดเมนติดตามของแพลตฟอร์มบนโดเมนย่อยของคุณ
มีผล สูงสุด 5 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 0.5 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
Google — Why Gmail marks messages as spam
กฎสำหรับผู้ส่งจำนวนมาก
ข้อกำหนดที่ Gmail และ Yahoo เผยแพร่สำหรับผู้ที่ส่งอีเมลในปริมาณมาก ข้อกำหนดเหล่านี้ใช้กับการส่งอีเมลเป็นชุด และจะข้ามสำหรับข้อความที่ไม่มีลักษณะดังกล่าว
เผยแพร่นโยบาย DMARC แล้ว compliance.dmarc_present
โดเมน From เผยแพร่ระเบียน DMARC หรือไม่ โดยแยกจากการที่ข้อความนี้ผ่านการตรวจสอบหรือไม่ Gmail และ Yahoo กำหนดให้ผู้ส่งอีเมลจำนวนมากต้องมีระเบียนนี้
หากไม่ผ่าน: เผยแพร่ระเบียน p=none ก็เพียงพอที่จะเป็นไปตามข้อกำหนด และทำให้คุณได้รับรายงานเพื่อนำไปดำเนินการต่อ
มีผล สูงสุด 6 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
RFC 9989 §4.7 — DMARC Policy Record Format
If this tag is not present in an otherwise syntactically valid DMARC Policy Record, then the record is treated as if it included "p=none".
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
Yahoo — Sender requirements and recommendations
List-Unsubscribe compliance.list_unsubscribe
ข้อความมีส่วนหัวสำหรับยกเลิกการสมัครที่โปรแกรมรับส่งอีเมลสามารถดำเนินการได้หรือไม่ Gmail และ Yahoo กำหนดให้ผู้ส่งอีเมลจำนวนมากต้องมีส่วนหัวนี้ และการไม่มีส่วนหัวนี้จะถูกใช้เป็นเกณฑ์กรองโดยไม่คำนึงถึงปัจจัยอื่น กฎนี้ใช้กับอีเมลที่ส่งเป็นรายการ จดหมายที่ขอให้ผู้รับยืนยันการสมัคร หรือแจ้งว่าการสมัครเสร็จสมบูรณ์แล้ว เป็นจดหมายที่ส่งถึงบุคคลหนึ่งเกี่ยวกับสิ่งที่บุคคลนั้นเพิ่งทำ CAN-SPAM เรียกข้อความประเภทนี้ว่าข้อความเชิงธุรกรรมหรือความสัมพันธ์ และทั้ง Gmail และ Yahoo ไม่ได้กำหนดให้มีส่วนหัวสำหรับยกเลิกการสมัครในข้อความดังกล่าว ดังนั้นการตรวจสอบนี้จะอ่านจดหมายก่อน การยืนยันการสมัคร จดหมายต้อนรับ จดหมายเชิงธุรกรรม หรือการแจ้งเตือนที่ไม่มีส่วนหัวของรายการจะไม่ถูกหักคะแนน และรายงานจะระบุว่าจดหมายนั้นถูกจัดเป็นประเภทใด จดหมายต้อนรับที่แทรกข้อเสนอจำนวนมากโดยผลแล้วคืออีเมลฉบับแรกของรายการ หากไม่มีส่วนหัวของรายการ การตรวจสอบจะแยกทั้งสองประเภทออกจากกันไม่ได้ และจะไม่หักคะแนนจากการคาดเดา หากจดหมายมี List-Unsubscribe หรือ List-Id แสดงว่าคุณประกาศเองว่าเป็นอีเมลรายการ และการตรวจสอบจะทำงานเช่นเดิม
หากไม่ผ่าน: เพิ่มส่วนหัว List-Unsubscribe ที่มี HTTPS URI แพลตฟอร์มส่งอีเมลทุกแพลตฟอร์มสามารถทำเช่นนี้ได้
มีผล สูงสุด 10 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา และ สูงสุด 1 คะแนนจาก 10 คะแนนในระบบคะแนนแบบคลาสสิก
RFC 2369 §3.2 — List-Unsubscribe
The List-Unsubscribe field describes the command (preferably using mail) to directly unsubscribe the user (removing them from the list).
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
Yahoo — Sender requirements and recommendations
ยกเลิกการสมัครด้วยคลิกเดียว compliance.one_click_unsubscribe
รูปแบบที่เข้มงวดกว่า: HTTPS URI, ส่วนหัว "List-Unsubscribe-Post" และลายเซ็น DKIM ที่ถูกต้องหนึ่งรายการซึ่งครอบคลุมส่วนหัวทั้งสอง ต้องมีครบทั้งสามอย่าง มิฉะนั้นผู้รับจะไม่แสดงปุ่ม เช่นเดียวกับการตรวจสอบ List-Unsubscribe การตรวจสอบนี้ใช้กับอีเมลที่ส่งเป็นรายการ ไม่ใช่การยืนยันหรือจดหมายต้อนรับ
หากไม่ผ่าน: สิ่งที่มักขาดคือลายเซ็น: แพลตฟอร์มลงลายเซ็นให้ "List-Unsubscribe" แต่ลืม "List-Unsubscribe-Post" ชื่อส่วนหัวทั้งสองต้องปรากฏในแท็ก h= ของลายเซ็นเดียวกัน
มีผล สูงสุด 8 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
RFC 8058 §4 — Additional Requirements
The List-Unsubscribe and List-Unsubscribe-Post headers MUST be covered by the signature and included in the "h=" tag of a valid DKIM-Signature header field.
RFC 8058 §3.1 — Mail Senders
The List-Unsubscribe header field MUST contain one HTTPS URI.
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
Yahoo — Sender requirements and recommendations
TLS สำหรับอีเมลจำนวนมาก compliance.tls_required
ข้อความมาถึงโดยมีการเข้ารหัสหรือไม่ การตรวจสอบโครงสร้างพื้นฐานครอบคลุมเรื่องนี้แล้ว หากการตรวจสอบนั้นทำงานไปแล้ว
หากไม่ผ่าน: ดูการตรวจสอบการเข้ารหัสระหว่างการรับส่งด้านบน
มีผล สูงสุด 5 คะแนนจาก 100 คะแนนในระบบคะแนนของเรา
Google — Send email over a secure TLS connection
Google — Sender guidelines FAQ: rules for 5,000+ messages a day
คำแนะนำ
ควรดำเนินการและไม่มีการคิดคะแนน ไม่มีสิ่งใดในส่วนนี้ที่ทำให้เสียคะแนนได้ ซึ่งเป็นการตัดสินใจด้านผลิตภัณฑ์ที่การทดสอบบังคับใช้
BIMI advisory.bimi
โดเมนเผยแพร่ระเบียน BIMI หรือไม่ ซึ่งจะแสดงโลโก้ข้างข้อความของคุณในไคลเอนต์บางตัว ก่อนอื่นต้องมีนโยบาย DMARC ที่บังคับใช้ และใบรับรองเครื่องหมายที่ผ่านการยืนยันซึ่งมีค่าใช้จ่าย
หากไม่ผ่าน: ควรทำเมื่อ DMARC อยู่ที่ quarantine หรือ reject และปริมาณการส่งคุ้มกับค่าใบรับรอง
คำแนะนำ ไม่มีผลต่อคะแนน
BIMI — draft specification, not yet an RFC
อายุและความยาวของคีย์ DKIM advisory.dkim_key_rotation
ความยาวของคีย์ที่ใช้ลงนามและระยะเวลาที่ใช้งานคีย์นั้นมา คีย์ที่สั้นจะมีต้นทุนในการโจมตีแบบออฟไลน์ต่ำลงในทุกปีที่ผ่านไป
หากไม่ผ่าน: เปลี่ยนไปใช้ 2048 บิตและหมุนเวียนตามกำหนดเวลา เผยแพร่ selector ใหม่ เปลี่ยนไปใช้ selector นั้นในการลงนาม แล้วจึงเลิกใช้ selector เก่า
คำแนะนำ ไม่มีผลต่อคะแนน
RFC 8301 §3.2 — Key Sizes
Since short RSA keys more easily succumb to off-line attacks, Signers MUST use RSA keys of at least 1024 bits for all keys. Signers SHOULD use RSA keys of at least 2048 bits.
Google — Set up DKIM
การส่งรายงาน DMARC advisory.dmarc_reporting
ที่อยู่ในระเบียน DMARC ของคุณจะได้รับข้อมูลจริงหรือไม่ หากที่อยู่สำหรับรับรายงานอยู่นอกโดเมนของคุณเอง RFC 9990 กำหนดให้โดเมนนั้นเผยแพร่การอนุญาตของตนเองก่อน โดยเป็นระเบียน TXT ที่ your-domain._report._dmarc.their-domain หากไม่มีระเบียนนี้ ผู้รับจะตัดที่อยู่นั้นทิ้ง: ไม่มีข้อความตีกลับ ไม่มีข้อผิดพลาด ไม่มีรายงาน นี่เป็นการตั้งค่าปกติ ไม่ใช่กรณีที่พบได้ยาก เพราะโดยทั่วไปที่อยู่ดังกล่าวจะอยู่กับผู้ให้บริการตรวจสอบ หรืออยู่ที่โดเมนหลักของคุณในขณะที่นโยบายอยู่บนโดเมนย่อยที่ใช้ส่ง กฎเดียวกันนี้ครอบคลุมรายงานความล้มเหลว โดย RFC 9991 อ้างถึงขั้นตอนเดียวกันสำหรับแท็ก ruf เราค้นหาระเบียนเดียวกับที่ผู้รับจะค้นหาและแสดงชื่อที่เราใช้ค้นหาให้คุณดู
หากไม่ผ่าน: ขอให้ผู้ดูแลโดเมนปลายทางเผยแพร่ระเบียน TXT ที่มี v=DMARC1 ณ ชื่อที่แสดงในผลการตรวจพบ โดยทั่วไปผู้ให้บริการตรวจสอบจะดำเนินการนี้ให้คุณเมื่อคุณเพิ่มโดเมนลงในบัญชีของผู้ให้บริการ ดังนั้นหากระเบียนหายไป เป็นไปได้ว่าโดเมนนั้นไม่เคยถูกเพิ่มในระบบของผู้ให้บริการ หากรายงานส่งไปยังโดเมนของคุณเองแทน ไม่จำเป็นต้องดำเนินการใดๆ
คำแนะนำ ไม่มีผลต่อคะแนน
RFC 9990 §4 — Verifying External Destinations
When a Mail Receiver discovers a DMARC Policy Record in the DNS, and the Organizational Domain at which that record was discovered is not identical to the Organizational Domain of the host part of the authority component of a [RFC3986] specified in the "rua" tag, the following verification steps MUST be taken:
RFC 9990 §4 — Verifying External Destinations
Where the above algorithm fails to confirm that the external reporting was authorized by the Report Consumer, the URI MUST be ignored by the Mail Receiver generating the report.
RFC 9991 §5 — Verifying External Destinations
In case of external destinations, a Mail Receiver who generates failure reports MUST use the Verifying External Destinations procedure described in Section 4 of [RFC9990], substituting the "ruf" tag where the "rua" tag appears in that procedure.
Google — Set up DMARC
DNSSEC advisory.dnssec
โดเมนได้รับการลงนามหรือไม่ SPF, DKIM และ DMARC ล้วนอยู่ใน DNS ดังนั้นผู้โจมตีที่ปลอมแปลงคำตอบ DNS ได้ก็สามารถปลอมแปลงทั้งสามรายการได้
หากไม่ผ่าน: เปิดใช้งานที่ผู้รับจดทะเบียนโดเมนของคุณ โดยปกติเป็นเพียงสวิตช์เดียว และผู้รับจดทะเบียนจะจัดการส่วนที่เหลือ
คำแนะนำ ไม่มีผลต่อคะแนน
RFC 4033 §2 — Definitions of Important DNSSEC Terms
Authentication Chain: An alternating sequence of DNS public key (DNSKEY) RRsets and Delegation Signer (DS) RRsets
MTA-STS advisory.mta_sts
โดเมนเผยแพร่นโยบายที่สั่งให้เซิร์ฟเวอร์อื่นปฏิเสธการส่งถึงคุณแบบไม่เข้ารหัสหรือไม่ นโยบายนี้ปกป้องอีเมลที่ส่งถึงคุณ ไม่ใช่อีเมลที่คุณส่ง
หากไม่ผ่าน: เผยแพร่ระเบียน TXT และไฟล์นโยบายผ่าน HTTPS (ใช้เวลาทำงานหนึ่งช่วงบ่าย และช่วยปิดช่องทางการโจมตีแบบดาวน์เกรด)
คำแนะนำ ไม่มีผลต่อคะแนน
RFC 8461 §3 — Policy Discovery
To discover if a recipient domain implements MTA-STS, a sender need only resolve a single TXT record.
ความยาวของเส้นทางตีกลับ advisory.return_path_length
ความยาวของที่อยู่สำหรับรับข้อความตีกลับ RFC 5321 กำหนดให้เซิร์ฟเวอร์ผู้รับต้องยอมรับข้อมูล 64 ออกเตตก่อนเครื่องหมาย @ และระบุไว้ในส่วนเดียวกันว่าไม่ควรมีระบบใดกำหนดขีดจำกัดที่สามารถหลีกเลี่ยงได้ อย่างไรก็ตาม หลายระบบยังคงกำหนดขีดจำกัด และข้อความที่เกินขีดจำกัดจะถูกปฏิเสธในขั้นตอน MAIL FROM ก่อนที่จะส่งเนื้อหาข้อความเสียอีก แพลตฟอร์มส่งอีเมลพบปัญหานี้จากการเข้ารหัสผู้รับไว้ในเส้นทางตีกลับเพื่อให้จับคู่ข้อความตีกลับกับผู้รับได้ ซึ่งทำให้ความยาวขึ้นอยู่กับว่าคุณส่งถึงใคร ไม่ใช่ขึ้นอยู่กับคุณ
หากไม่ผ่าน: ลดความยาวของส่วนคงที่ที่แพลตฟอร์มของคุณเติมไว้ด้านหน้า หรือเปลี่ยนโดเมนสำหรับรับข้อความตีกลับเป็นโดเมนที่สั้นกว่า หากคุณเปลี่ยนทั้งสองอย่างไม่ได้ ที่อยู่ซึ่งมีความเสี่ยงคือที่อยู่ของผู้สมัครรับข้อมูลที่ยาวที่สุด ดังนั้นจึงควรวัดที่อยู่ที่ยาวที่สุดในรายการของคุณแทนการวัดค่าเฉลี่ย
คำแนะนำ ไม่มีผลต่อคะแนน
RFC 5321 §4.5.3.1.1 — Local-part
The maximum total length of a user name or other local-part is 64 octets.
RFC 5321 §4.5.3.1 — Size Limits and Minimums
Every implementation MUST be able to receive objects of at least these sizes.
Haraka — the address parser that enforces the 64-octet local-part, and the flag that relaxes it
การรายงาน TLS advisory.tls_rpt
โดเมนร้องขอรายงานหรือไม่เมื่อมีผู้ส่งไม่สามารถนำส่งอีเมลมายังโดเมนผ่าน TLS ได้ ใช้คู่กับ MTA-STS: นโยบายที่ไม่มีการรายงานทำให้คุณไม่สามารถตรวจสอบได้ว่านโยบายทำงานอยู่หรือไม่
หากไม่ผ่าน: เพิ่มระเบียน TXT พร้อมที่อยู่ที่รับรายงานรายวัน
คำแนะนำ ไม่มีผลต่อคะแนน
RFC 8460 §3 — Reporting Policy
A domain publishes a record to its DNS indicating that it wishes to receive reports.